PDA

View Full Version : Thanks for denying UT to japan !!!


Azumi123
21st December, 2001, 05:45 AM
I would like to give a big thanks to all you cshp staff for denying japanese UT players the right to play online !!!! Also a big big thanks for helping me waste my money buying UT !!. There are now VERY few japanese players of UT ( only people with the USA import version ) You did a good job. Im now going to take my copy of UT and give it to my dog ( the only one who still has the ability to play with it ) .

DarkByte
21st December, 2001, 06:01 AM
Azumi, instead of coming and being mad on your first post, i'm sure that helping me understand what doesnt work would be more productive than saying it just doesnt work.

Give me some details like telling how it reacts, etc. Also, if the server/client crashes .. paste the error message. Etc.

I have no intent of denying online play to anyone. I just want clean play.

Just help me to help you.

Azumi123
21st December, 2001, 06:09 AM
That was not my first post on the topic , read back a long way ( when cshp 40 and 4+ were first released ). Anyway ill explain again what happens. I double click on a server to join it , it loads , the game appears and a cshp window comes up with cshp at the top and NOTHING in the window. I then get disconnected from the server without explanation. DrSiN told me to ask for a report from the server i try to connect to but i think we all know that the email addresses supplied are fake ones. This occurs in the jpn version of UT in general. however a server running an older version of cshp is fine.

drominore
21st December, 2001, 06:49 AM
Not quite sure what you mean by e-mails are fake but I'd be willing to setup a port for testing this prob so we can all see what it does....

Azumi123
21st December, 2001, 06:54 AM
I just tested it myself by installing cshp 4+ and dedicating , then i joined via lan game , and it kicked me , below is the exact log as it appeard from the server console , hope someone can help.


Init: Game engine initialized
Log: Startup time: 6.118251 seconds
DevNet: NotifyAcceptingConnection: Server MyLevel accept
NetComeGo: Open MyLevel 12/21/01 14:49:21 169.254.37.164:2670
DevNet: NotifyAcceptingChannel Control 0 server Level DM-Agony.MyLevel: Accepted
DevNet: Level server received: HELLO REVISION=0 MINVER=400 VER=436
DevNet: Level server received: NETSPEED 20000
Log: Client netspeed is 20000
DevNet: Level server received: LOGIN RESPONSE=-708492366 URL=Index.unr?LAN?Name=En|gmA?Class=BotPack.TMale1?team=0?skin=CommandoSkins.cmdo?Face=CommandoSkins.Blake?Voice=BotPack.VoiceMaleOne?Checksum=NoChecksum
DevNet: Login request: Index.unr?LAN?Name=En|gmA?Class=BotPack.TMale1?team=0?skin=CommandoSkins.cmdo?Face=CommandoSkins.Blake?Voice=BotPack.VoiceMaleOne?Checksum=NoChecksum
DevNet: Level server received: JOIN
DevNet: Join request: Index.unr?LAN?Name=En|gmA?Class=BotPack.TMale1?team=0?skin=CommandoSkins.cmdo?Face=CommandoSkins.Blake?Voice=BotPack.VoiceMaleOne?Checksum=NoChecksum
ScriptLog: Team 0
ScriptLog: Login: En|gmA
Log: Possessed PlayerPawn: TMale1 DM-Agony.TMale0
DevNet: Join succeeded: En|gmA
ScriptLog: [CSHPs][En|gmA] Spawning C
ScriptLog: [CSHPs][En|gmA] Client has logged in @<hidden> 35.3.0.0
ScriptLog: #### -------------------------------- ####
ScriptLog: #### HACKED CLIENT DETECTED ####
ScriptLog: #### -------------------------------- ####
ScriptLog: #### - Player Name : En|gmA
ScriptLog: #### - Player IP : 169.254.37.164:2670
ScriptLog: #### - Method : UCRC Failure (Unknown Cheat)
ScriptLog: #### - Misc : UnrealShare 436
ScriptLog: #### - Action : Kicked
ScriptLog: #### - TimeStamps : 36.1.0.0
ScriptLog: #### - Auth. Code : 1355618304
ScriptLog: #### - Date/Time: 12-21-2001 / 14:49:26
ScriptLog: #### -------------------------------- ####
NetComeGo: Close TcpipConnection0 12/21/01 14:49:27
DevNet: NotifyAcceptingConnection: Server MyLevel accept
NetComeGo: Open MyLevel 12/21/01 14:49:33 169.254.37.164:2670
Log: UDP recvfrom error: 10054
DevNet: Connection timed out after 150.000000 seconds (150.048477)
NetComeGo: Close TcpipConnection1 12/21/01 14:52:03
>

drominore
21st December, 2001, 06:59 AM
OK, thats with CSHP and its probably just a checksum diff from the language characters... What happens when you join a UTPure server? Try out my public in the sig below and let the staff know what happens. I'll keep an eye on the logs for the next few mins to see if you join then leave or what..

DarkByte
21st December, 2001, 07:09 AM
Ok, i guess something had not been cleared up at the time. But with UTPure, you shall not get this kind of mismatches. If you do let me know.

Azumi123
21st December, 2001, 07:13 AM
Thanks for the info and leting me test out on your server. I hope that soon all UT servers change to the new version. Thanks again.
If there is a way of resolving the above error i printed then i would like to know how.

drominore
21st December, 2001, 07:19 AM
Saw ya on but just missed saying howdy before the maps rotated... Alot of servers at the top end are either already running DB's UTPure or switching to it, so don't be too shy about coming around once in a while... Other than those guys on the pub side REALLY like to kick the cr** out of the new guy! ;-)

DarkByte
21st December, 2001, 07:24 AM
Azumi,

The only way i know of that could fix it for you is to install the US patch 4.36. Other than that .. humm .. not that i know of.

2COOL4-U
21st December, 2001, 07:10 PM
I tought the japanese localization wasn't finished by epicgames as I see a lot of code related to japanese support commented. Perhaps that's why CSHP disconnects you, perhaps epic games removed the comments to give you guys a japanese localization of UT.

I am just guessing :)

HogMan
21st December, 2001, 09:07 PM
Well, heres another server to try. I run UTPure so you should be able to play on mine. Its CTF with Strangelove mod. Give it a try.

HogMan's Haven (http://unreal://ut.soggybread.com:7777)

Azumi123
23rd December, 2001, 04:20 AM
I looked through my UT system directory and found that there is a file called " UTjapanese.u " and there is reference in the unrealtournament.ini file to that file, could this be causing the hacked client error on 40 and 4+ ?. Inside the UTjapanese file it has all sorts of lines to do with scale and fonts. I also found that the textures , when installing from cd , read : japan textures , maybe this mean that some of the textures in the jpn version are different ( although i cant see why ). If you would like a copy of the nessasary japan files for you to work with aswell as the US version then just ask i woul dbe glad to contribute to japan's continuing on the UT scene. Right now everyone i know has switched to either Q3 , RTCW or T2. lets try and get them back on the UT scene. Thanks once again for all your support on this and im sorry for comming in with such a bad attitude towards you. BTW the server which somebody posted a link to ( the strange love one ) gives a mismatch error " version "de" mismatch " or something like that.

2COOL4-U
23rd December, 2001, 10:59 AM
Yep that would cause troubles with CSHP...