You are an unregistered user, you can register here
Navigation

Information

Site

Donations
If you wish to make a donation you can by clicking the image below.


Site Sponsor

BeyondUnreal News

 
Go Back   The Unreal Admins Page > Forums > Unreal Admins > Unreal Tournament 2003/2004 > UT2003/4 Server - Linux Specific

Reply
Thread Tools Display Modes
  #1  
Unread 13th May, 2007, 07:20 PM
TripleE TripleE is offline
Forum Newcomer
 
Join Date: May 2007
Posts: 4
Default MissingIni and MisingIni error

I have been trying to get a UT2004 server running on archlinux (64-bit) and ubuntu (32-bit) for a while now, but I keep getting the following error (using ubuntu in the example):
Code:
user@server:/home/ut2004$ System/ucc-bin server ONS-Torlan?Game=Onslaught.OnslaughtFull ini=System/Default.ini log=server.log -nohomedir
MisingIni

History: 

Exiting due to error
And if I try:
Code:
user@server:/home/ut2004$ System/ucc-bin server ONS-Torlan?Game=Onslaught.OnslaughtFull ini=Default.ini log=server.log -nohomedir
MissingIni

History: 

Exiting due to error
I am assuming that my INI file is not correct. I did not do many changes to it. Is there a good INI file that I can start off with or a good howto for a linux UT2004 onslaught server?

EDIT: by the way, I am running the dedicatedserver3339-bonuspack

Last edited by TripleE : 13th May, 2007 at 07:22 PM. Reason: Add info
Reply With Quote
  #2  
Unread 13th May, 2007, 08:53 PM
Al Al is offline
Holy Shit!!
 
Join Date: Aug 2005
Location: Philadelphia, PA
Posts: 815
Default

You could give the INI Generator a try: http://www.unrealadmin.org/inigenerator/ut2004
Reply With Quote
  #3  
Unread 13th May, 2007, 09:08 PM
TripleE TripleE is offline
Forum Newcomer
 
Join Date: May 2007
Posts: 4
Default

Thanks for the tip, but unfortunately it did not work. I am getting the same error.
Reply With Quote
  #4  
Unread 14th May, 2007, 11:30 PM
Naked_Ape's Avatar
Naked_Ape Naked_Ape is offline
Holy Shit!!
 
Join Date: Jun 2003
Location: .gif
Posts: 584
Default

You need to be in System dir to start the server.
Reply With Quote
  #5  
Unread 15th May, 2007, 04:03 AM
TripleE TripleE is offline
Forum Newcomer
 
Join Date: May 2007
Posts: 4
Default

Quote:
Originally Posted by Naked_Ape View Post
You need to be in System dir to start the server.
Wow, it was that simple. Thanks for the help. It works great now on both machines.
Reply With Quote
  #6  
Unread 8th June, 2007, 02:15 AM
NayusDante NayusDante is offline
Forum Newcomer
 
Join Date: Mar 2004
Posts: 11
Default

nayusdante@moogle:~/Desktop/ut2004/System$ ./ucc-bin-linux-amd64 server
Executing Class Engine.ServerCommandlet
Missing Class Class Editor.TransBuffer
Can't find 'intAMasterServerUplinkexecForceGameStateRefresh' in 'IpDrv.dll'
Executing UObject::StaticShutdownAfterError
Can't find 'intAMasterServerUplinkexecForceGameStateRefresh' in 'IpDrv.dll'

History:

Exiting due to error
Exiting.
FileManager: Reading 0 GByte 12 MByte 506 KByte 120 Bytes from HD took 1.038384 seconds (0.387344 reading, 0.651040 seeking).
FileManager: 0.000000 seconds spent with misc. duties
Name subsystem shut down


That's what I get when I run it in ./Server (AMD64).
Reply With Quote
  #7  
Unread 8th June, 2007, 02:51 AM
Naked_Ape's Avatar
Naked_Ape Naked_Ape is offline
Holy Shit!!
 
Join Date: Jun 2003
Location: .gif
Posts: 584
Default

Quote:
Originally Posted by NayusDante View Post
nayusdante@moogle:~/Desktop/ut2004/System$ ./ucc-bin-linux-amd64 server
That is a incomplete command invocation. Read the dedicated server HOWTO.

Quote:
Originally Posted by NayusDante View Post
Can't find 'intAMasterServerUplinkexecForceGameStateRefresh' in 'IpDrv.dll'
Most likely a corrupt IpDrv.dll, this is the MD5 of mine which is v3369-2 and working just fine: 3b6a1cd75ac5ece6d47500a30129a4d8
Reply With Quote
  #8  
Unread 8th June, 2007, 03:47 AM
NayusDante NayusDante is offline
Forum Newcomer
 
Join Date: Mar 2004
Posts: 11
Default

Well, the server package I had was 3369 from the start (had to look around for it). I see why everyone gets 3339 or whatever and patches from that. The 3369-2 patch files overwritten on what I had fixed everything and it runs now. I wasn't concerned about command syntax before as much as just getting the damn thing to run.

nayusdante.servegame.com:7777 if you're interested.

If that doesn't work, 24.96.6.213:7777
Reply With Quote
  #9  
Unread 16th October, 2009, 02:07 AM
kaelanm kaelanm is offline
Forum Newcomer
 
Join Date: Oct 2009
Posts: 1
Default ...

Okay I'm kind of new at this and don't really understand computer terms...when I started Unreal Tournament I got a message that said misingIni and I'm not sure what it means.. can anyone help me ?
Reply With Quote
  #10  
Unread 25th April, 2013, 07:58 AM
chrisjonah7741 chrisjonah7741 is offline
Forum Newcomer
 
Join Date: Apr 2013
Posts: 1
Default

yo dude i can send you a ini.file if you want it haha

Last edited by chrisjonah7741 : 27th April, 2013 at 06:31 AM.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT +1. The time now is 01:26 AM.


Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

All pages are copyright The Unreal Admins Page.
You may not copy any pages without our express permission.