You are an unregistered user, you can register here
Go Back   The Unreal Admins Page > Forums > Unreal Admins > Unreal Tournament 3 > UT3 Server - Windows Specific

Reply
Thread Tools Display Modes
  #1  
Unread 19th October, 2008, 03:21 AM
UnrealGrrl UnrealGrrl is offline
Forum Newcomer
 
Join Date: Aug 2004
Posts: 12
Default (HELP!) How to Setup Custom Models on Server

help!

ok, I'm trying to install a custom player model on my server and not having any luck. I installed all the files for the model on my (hosted) server by FTPing them to the proper folders and then also put them on my redirect.
I have alot of custom maps redirecting on my server with no problems, and AllowDownloads in utengine.ini set to true.

but after upping the model files it doesnt send it to the player like it does for the maps.

Anyone running custom models out there that can give any help or suggestions to help make this work?

Thanks!

Sioux
www.UnrealGrrl.com
Reply With Quote
  #2  
Unread 23rd October, 2008, 08:29 PM
UnrealGrrl UnrealGrrl is offline
Forum Newcomer
 
Join Date: Aug 2004
Posts: 12
Default

anyone out there running custom models that can let me know how they have this setup? or anyone from Epic or anywhere know how this is supposed to work?

thanks

Last edited by UnrealGrrl : 24th October, 2008 at 12:59 AM.
Reply With Quote
  #3  
Unread 23rd October, 2008, 11:14 PM
SoNY_scarface SoNY_scarface is offline
Holy Shit!!
 
Join Date: Mar 2007
Posts: 1,687
Default

Sorry, what exactly are you trying to achieve?
__________________








http://www.unrealkillers.com The home of siege UT99! Accept no imitations.
Reply With Quote
  #4  
Unread 24th October, 2008, 12:41 AM
UnrealGrrl UnrealGrrl is offline
Forum Newcomer
 
Join Date: Aug 2004
Posts: 12
Default

Quote:
Originally Posted by SoNY_scarface View Post
Sorry, what exactly are you trying to achieve?

I'm trying to install a custom player model on my UT3 server and not having any luck.

I installed all the files for the model on my (hosted) server by FTPing them to the proper folders and then also put them on my redirect.

But, with the files in both places (on the server and on redirect) when a player joins the server, the files are never pushed to the player.

So I'm wondering what else i need to do to make this work?

(I have alot of custom maps redirecting on my server with no problems, so i know redirect works)

AllowDownloads in utengine.ini is set to true. (tried with false for the heck of it and didnt make a difference)

I also tried editing the CustomChar.ini file to include the custom model info, also tried delting the CustomChar.ini and let the server recreate it and that didnt help either. I even recompiled the models .upk files with AllowDownload=True just to make sure it was set right and that didnt work

Thanks for any suggestions/solutions!
__________________
Sioux
www.UnrealGrrl.com


Last edited by UnrealGrrl : 24th October, 2008 at 12:48 AM.
Reply With Quote
  #5  
Unread 24th October, 2008, 04:57 PM
CVROY CVROY is offline
Rampage
 
Join Date: Oct 2004
Posts: 58
Default

I believe only clients need to have the model installed and they will see it if anyone is using it. I am not sure if UT3 has the ability to push models to clients from the server like UT2004 did.
Reply With Quote
  #6  
Unread 24th October, 2008, 09:28 PM
UnrealGrrl UnrealGrrl is offline
Forum Newcomer
 
Join Date: Aug 2004
Posts: 12
Default

well i know i can see other players using custom models if they have them installed, what i dont seem to be able to do is get the server to send the models to anyone and i am fairly sure that ive logged onto servers and had to download player models. (i know ive downloaded other custom content besides maps too, like weapons and utilities, utcomp etc.) would UT3 be actively stopping a model from being sent or be incapable of pushing that content? the model author seemed to think it should work... i dont even know who to ask at Epic anymore.
__________________
Sioux
www.UnrealGrrl.com

Reply With Quote
  #7  
Unread 25th October, 2008, 08:19 PM
UnrealGrrl UnrealGrrl is offline
Forum Newcomer
 
Join Date: Aug 2004
Posts: 12
Default

Update: made some progress but still not working right.

If I create a "Published" folder under the install \UTGame\Published\CookedPC\CustomChars\ and place the model files in there (instead of under the default \UTGame\CookedPC\CustomChars) then the Faction .u Script and Sound files download to the player (but not .upk Model files). So the game actually sees the faction, and will add a bot from the faction to start the game, but it just shows up as "demoguy" (even when included at the start of the match).

So once again, is anyone running a custom model and know what the right setup should be to get the model to dl to the player? (as above, i know if the players already have it they will see eachother) the issue is for those that don't have the model already.)

Thanks for any ideas, suggestions etc.
__________________
Sioux
www.UnrealGrrl.com

Reply With Quote
  #8  
Unread 8th June, 2009, 12:02 PM
-]HcF.Animus[- -]HcF.Animus[- is offline
Forum Newcomer
 
Join Date: Oct 2004
Posts: 2
Default

sorry to say but it is not possible to force people to download your models on your server.
people can see the models that other people have only if they have the model installed themself.

i know this because i wandered around with this same quastion multiple times.
UT2004 has the same problem.

you should ask Epic or dive in Unreal script and find out yourself.
Reply With Quote
  #9  
Unread 27th July, 2009, 04:47 PM
UnrealGrrl UnrealGrrl is offline
Forum Newcomer
 
Join Date: Aug 2004
Posts: 12
Default

just to close this finally, (i thought i already did here - but...) at least the tech details of why. i never did get a reply as to why they wouldnt create or hack a way to allow it... oh well, maybe UT4.

This is from the ut3 servers list where Epic confirmed the following details:

-----Original Message-----
From: UT3 Servers On Behalf Of Josh Adams
Sent: Wednesday, February 25, 2009 11:04 PM
To: UT3SERVERS at LIST.EPICGAMES.COM
Subject: Re: [ut3servers] Beta patch 2 (models)


The characters are sent from server to client as a string not as object
pointers, which allows the client to load it or use instead a best match
instead - due to the max number of custom chars allowed.

The game can't make a character without .ini sections to turn the string
into a char made out of merged pieces - and .ini files are not transferred
as objects are.

So, characters are handled in a very special way to handle the
customization, etc. This is hy they are treated differently than other
objects.


Josh


-----Original Message-----
From: UT3 Servers On Behalf Of Josh Markiewicz
Sent: Thursday, February 26, 2009 8:31 AM
To: UT3SERVERS at LIST.EPICGAMES.COM
Subject: Re: [ut3servers] Beta patch 2 (models)

I believe this was addressed in an email to this list some time ago. The
packages can be downloaded, but there are .ini additions for the custom
chars that won't come across because we don't support the
download/transmission of .ini settings.

Its not so hard for people to download a character pack. Maybe they prefer
the control over the content the see/get? Pull rather than push.


________________________________________
From: UT3 Servers On Behalf Of Sioux [sioux at UNREALGRRL.COM]
Sent: Wednesday, February 25, 2009 10:43 PM
To: UT3SERVERS at LIST.EPICGAMES.COM
Subject: Re: [ut3servers] Beta patch 2 (models)

Why not? Is there a reason to not allow players to download custom player
models from the server? It sounds like the functionality is already there
and that the package download is just being blocked. We used to be able to
download player models from the server in previous UTs and we can still send
custom maps and vehicles and weapons. Why not player models?

-----Original Message-----
From: UT3 Servers On Behalf Of Josh Markiewicz
Sent: Wednesday, February 25, 2009 2:15 PM
To: UT3SERVERS at LIST.EPICGAMES.COM
Subject: Re: [ut3servers] Beta patch 2

The client knows all the indices necessary to make the custom character, but
without the custom packages on their machine there already, they won't get
the custom character. There is no plans to change this behavior.

Josh
__________________
Sioux
www.UnrealGrrl.com

Reply With Quote
  #10  
Unread 19th October, 2009, 11:58 AM
-]HcF.Animus[- -]HcF.Animus[- is offline
Forum Newcomer
 
Join Date: Oct 2004
Posts: 2
Default

were did you get that
anyway, i wont bother to figure out a solution for Epics laziness and clean up there mess.
but out of curiosity, if its only disability is sending the ini's wouldnt you be able to transfer the upk's ?
and what is it exactly that blocks the .ini's from being transfered?
i dont think i fully understand but if the above is the only limitation im sure there is a possible solution for it.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT +1. The time now is 06:00 PM.


Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

All pages are copyright The Unreal Admins Page.
You may not copy any pages without our express permission.