You are an unregistered user, you can register here
Go Back   The Unreal Admins Page > Forums > Unreal Admins > Unreal Tournament 2003/2004 > UT2003/4 Server - Windows Specific

Reply
Thread Tools Display Modes
  #1  
Unread 15th May, 2011, 02:46 PM
KyleS71 KyleS71 is offline
Killing Spree
 
Join Date: Sep 2006
Location: s yorkshire, UK
Posts: 47
Default Problems with Ip on dedi server

Hi,
I've got a windows 2008 dedicated server. and i've been allocated 3 ip address. Ive added the ips to the network so i can now ping all the ips from my pc.
and ive done server command like:
Code:
ucc server CTF-w00tabolous2k4?Game=XGame.XCTFGame?Mutator=XGame.MutInstaGib ini=UT2004.ini log=server.log multihome=111.111.111.2 port=$8888 -nohomedir
The server starts fine. i can login to the webadmin on the ip i put in the command line multihome=111.111.111.2 But i cannot ping the server or join the server ingame. Ive allowed the program with windoes firewall.

Any idea much appreciated.
Thankyou
Reply With Quote
  #2  
Unread 22nd May, 2011, 10:09 AM
KyleS71 KyleS71 is offline
Killing Spree
 
Join Date: Sep 2006
Location: s yorkshire, UK
Posts: 47
Default

Hi did the same with ut99 on same server with line:
Code:
ucc server CTF-DukuCB6?game=Botpack.CTFGame?mutator=ZPPure7G.AccuGib,SmartCTF_4DPlusPlusv3.SmartCTF,MapVoteLA13.BDBMapVote?MaxPlayers=10 ini=UnrealTournament.ini multihome=109.236.81.188 port=7777 -nohomedir
And this worked. so guessing just something wrong with the setup of server or command line.
Reply With Quote
  #3  
Unread 22nd May, 2011, 10:24 AM
(G)ott's Avatar
(G)ott (G)ott is offline
Dominating
 
Join Date: Apr 2010
Posts: 104
Default

I dont know many about UT2k servers, but could it be this:

Code:
port=$8888

greetz (G)ott
__________________
XServerQuery
XBrowser


I know that my english is shit, but I hope you understand me
Reply With Quote
  #4  
Unread 22nd May, 2011, 02:20 PM
KyleS71 KyleS71 is offline
Killing Spree
 
Join Date: Sep 2006
Location: s yorkshire, UK
Posts: 47
Default

yea i thought could be that aswell (G)ott. but removed the $ so it was same as ut99 one. and still crashes
This is the error should have put it before :/

Code:
UdpGamespyQuery CTF-w00tabolous2k4.UdpGamespyQuery (Function IpDrv.UdpGamespyQue
ry.PreBeginPlay:0167) Assertion failed, line 58

History: FFrame::Serialize <- UObject::ProcessEvent <- (UdpGamespyQuery CTF-w00t
abolous2k4.UdpGamespyQuery, Function IpDrv.UdpGamespyQuery.PreBeginPlay) <- ULev
el::SpawnActor <- (UdpGamespyQuery) <- UObject::ProcessEvent <- (MasterServerUpl
ink CTF-w00tabolous2k4.MasterServerUplink, Function IpDrv.MasterServerUplink.Beg
inPlay) <- BeginPlay <- UGameEngine::LoadMap <- LocalMapURL <- UGameEngine::Brow
se <- UGameEngine::Init <- UServerCommandlet::Main

Exiting due to error

Last edited by KyleS71 : 22nd May, 2011 at 02:26 PM.
Reply With Quote
  #5  
Unread 22nd May, 2011, 02:25 PM
KyleS71 KyleS71 is offline
Killing Spree
 
Join Date: Sep 2006
Location: s yorkshire, UK
Posts: 47
Default

Found problem:
Code:
[IpDrv.UdpGamespyQuery]
MinNetVer=0
OldQueryPortNumber=0
Changed to
Code:
[IpDrv.UdpGamespyQuery]
MinNetVer=0
OldQueryPortNumber=7787
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT +1. The time now is 05:19 PM.


Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

All pages are copyright The Unreal Admins Page.
You may not copy any pages without our express permission.